Please select To the mobile version | Continue to access the desktop computer version

Electronic Engineer Discuss

12Next
Return to list New
View: 429|Reply: 13

USB oscilloscope not working - HANTEK6254BC

[Copy link]

27

Threads

73

Posts

73

Credits

注册会员

Rank: 2

Credits
73
Post time 2021-8-26 15:36:19 | Show all posts |Read mode
Customer consultation


Good morning, I have problems when connecting my usb oscilloscope for the first time (HANTEK 6254BC 250Mhz 1GSa / s), the software that came on the CD together with the oscilloscope and also the latest version available on the web do not open until I disconnect from the computer the oscilloscope.

And when I try to connect it back to the computer, the software is looking for the device but never finds it. The computer recognizes it correctly since it has the enclosed drivers installed (I have tried the ones that came on the CD and the ones available on the web for Win10) but the Hantek6000 software does not detect the oscilloscope.


I have been testing the SDK that is offered for developers, and the basic functions that communicate with the Driver seem to work correctly (dsoHTSearchDevice and dsoHTDeviceConnect), but when I want to use functions that communicate with the FPGA my program freezes in any of these functions that I have tried (dsoSetUSBBus and dsoInitHard), which are the basic functions to use to communicate with the oscilloscope, so there must be the same problem with the Hantek6000 software.

I have also tried to run it on Win7 and the same problem occurs


So my conclusion is that it seems that the FPGA does not have any firmware stored in it for the reasons that I have explained and because the RGB led that is on one side of the coaxial connectors of the 4 channels never lights up in any color.

So how can I load the firmware on the HANTEK6254BC usb oscilloscope? Can you send me the firmware for this device and the steps that I have to perform?
Or do you think the problem may be somewhere else?


Thank you very much, I look forward to your help



Reply

Use magic Report

27

Threads

73

Posts

73

Credits

注册会员

Rank: 2

Credits
73
 Author| Post time 2021-8-26 15:37:28 | Show all posts
Reply


It may be that the voltage of the USB port is insufficient. Please connect a 5V@2A power adapter to the red connector of the USB cable before connecting the oscilloscope to the computer.

0

Threads

6

Posts

6

Credits

新手上路

Rank: 1

Credits
6
Post time 2021-8-26 19:00:04 | Show all posts
I just tried what you told me with a 5v 2.4A adapter and it had no effect, the same problem still occurs.
It seems that it is the SPI memory of the FPGA that may be giving a problem because I do not get any response from the FPGA.
The led next to the BNC connectors does not light up at any time. The only thing that lights up is a green LED that is close to the FPGA indicating that it has power.
What I do? Could you send me the binary firmware to try to load it into the SPI memory?

142

Threads

1956

Posts

2117

Credits

版主

Rank: 7Rank: 7Rank: 7

Credits
2117
Post time 2021-8-27 08:24:18 | Show all posts
Is the green LED that is close to the FPGA always on?

0

Threads

6

Posts

6

Credits

新手上路

Rank: 1

Credits
6
Post time 2021-8-28 09:55:18 | Show all posts
Yes, it is all the time on. It seems like it is not controlled by any pin on the FPGA, it is connected to the power rail.

142

Threads

1956

Posts

2117

Credits

版主

Rank: 7Rank: 7Rank: 7

Credits
2117
Post time 2021-8-30 10:30:20 | Show all posts
Please upload the version on the mainboard.

0

Threads

6

Posts

6

Credits

新手上路

Rank: 1

Credits
6
Post time 2021-8-31 07:47:22 | Show all posts
In the image attached with this text you can see the pcb of the device, the identifier of the pcb is DSO6XX4    V1.08    20170905

This post contains more resources

You have to Login for download or view attachment(s). No Account? Register

x

142

Threads

1956

Posts

2117

Credits

版主

Rank: 7Rank: 7Rank: 7

Credits
2117
Post time 2021-8-31 08:29:12 | Show all posts

Please refer to the attachment to flash the fpga.



This post contains more resources

You have to Login for download or view attachment(s). No Account? Register

x

0

Threads

6

Posts

6

Credits

新手上路

Rank: 1

Credits
6
Post time 2021-8-31 16:59:21 | Show all posts
Same problem, the update program says that the upload was successful, but it still does not work, the led next to the BNC connectors still never lights up and the Hantek6000 program still does not find the device because it does not respond.
Maybe I could flash the memory physically? In the case that it is also the problem that the updates do not work
I have several tools and surely could do it with a little help
Or do I try something else?

142

Threads

1956

Posts

2117

Credits

版主

Rank: 7Rank: 7Rank: 7

Credits
2117
Post time 2021-9-2 11:52:13 | Show all posts

Do you have anyone of the two tools?



This post contains more resources

You have to Login for download or view attachment(s). No Account? Register

x
12Next
Return to list New
You have to log in before you can reply Login | Register

Points Rules

Dark room|Mobile|Archiver|Electronic Engineer Discuss

2021-9-18 18:51 GMT+8 , Processed in 0.389462 second(s), 22 queries .

Powered by Discuz! X3.2

© 2001-2013 Comsenz Inc.

Quick Reply To Top Return to the list