Please select To the mobile version | Continue to access the desktop computer version

Electronic Engineer Discuss

View: 496|Reply: 6

HT2D72 - Menu issue

[Copy link]

109

Threads

1795

Posts

1956

Credits

版主

Rank: 7Rank: 7Rank: 7

Credits
1956
Post time 2021-3-1 11:19:27 | Show all posts |Read mode

Customer Consultation

I have a problem with my new HT2D72:
- when pressing the blue Menu-knob nothing happends,
- when I use the software Hantek2xx2 and click on DMM - the program is shutting down telling cant measure no data....

Please advise me what to do!

When I try to update the firmware but I get nonsense files when downloading the *.dfu file I just get a notefile. I need that you send me the a file with an upgrade/repair firmware


Reply

Use magic Report

109

Threads

1795

Posts

1956

Credits

版主

Rank: 7Rank: 7Rank: 7

Credits
1956
 Author| Post time 2021-3-11 11:15:44 | Show all posts
mar replied at 2021-3-10 17:16
Hi AMY

1. I bought 4 weeks ago brand new HT2D72. Nice and usefull tool but unfortunately I found t ...

Please refer to this:



This post contains more resources

You have to Login for download or view attachment(s). No Account? Register

x

109

Threads

1795

Posts

1956

Credits

版主

Rank: 7Rank: 7Rank: 7

Credits
1956
 Author| Post time 2021-3-1 11:25:23 | Show all posts
Reply

Menu-knob is available in the scope interface.
Please share me the firmware version and software version to study.
If there's a video to illustrate your problem, it's even better.

0

Threads

1

Posts

1

Credits

新手上路

Rank: 1

Credits
1
Post time 2021-3-3 01:33:15 | Show all posts
After detaching the HT2D72 from the software it went dead. The Power on knob was lighting and still the right knob, stop run waweform, is continuosly lighting red.  I cant start the unit again - nothing happends when I try to start it!

The unit seems to be complete out of order! What to do?

Best Regards

0

Threads

1

Posts

1

Credits

新手上路

Rank: 1

Credits
1
Post time 2021-3-4 22:20:08 | Show all posts
staffanrd replied at 2021-3-3 01:33
After detaching the HT2D72 from the software it went dead. The Power on knob was lighting and still  ...

I was facing a similar problem. After detaching the device from the SW, it did not react anymore. The way I was recovering the device, was to open it and to remove the batteries. After plugging the batteries back again, the device started normally again.
The reason I found out was that not all drivers were installed properly, mainly I had not yet installed the drivers from STMicroelectronics part of the "Programming Tool" package (DfuSe_Demo_...) that you may download from the webpage.
Hope this helps you.

109

Threads

1795

Posts

1956

Credits

版主

Rank: 7Rank: 7Rank: 7

Credits
1956
 Author| Post time 2021-3-5 10:45:21 | Show all posts
staffanrd replied at 2021-3-3 01:33
After detaching the HT2D72 from the software it went dead. The Power on knob was lighting and still  ...

Please remove the batteries and re install them to resume starting.

0

Threads

1

Posts

1

Credits

新手上路

Rank: 1

Credits
1
Post time 2021-3-10 17:16:59 | Show all posts
Edited by mar at 2021-3-11 04:12

Hi AMY

1. I bought 4 weeks ago brand new HT2D72. Nice and usefull tool but unfortunately I found the same issues what have been descibed above in several posts in this thread.
Finally I took decision to do upgrade a new firmware and during this operation it hanged in "Erasing Phase" .
I have two devices that I can use to apply new firmware:  
https://abc-rc.pl/product-pol-54 ... 2303HX-Arduino.html
https://allegro.pl/oferta/konwer ... wYmI1YjhlNDAzOTc%3D

For security reasons I don't use files from other places like youtube and others. I prefer only to use orginal files.
Could you share the bundle of files what I could use and bring my Hantek back to work ?

2. I've prepared new environment fresh Windows 10 on dedicated lenovo T410 and when I did simple test that above devices work I saw
    a message that I've never seen before "serial port is used by other device". Have you ever seen something like this?
        I could handle with it by applying drivers "ftdiport.inf". Enyway the best what I have seen is a massage from Flash Loader Demo:
        "No response from the target, the boot loader can not be started. Please verify the boot mode configurationand the flash
         protection status, Reset your device and start again"
         
   On the board I see description HT2xxx_KB 2018.11 Rev9

         As I mentioned: Could you share for me some files with short description what would help me to bring the hantek back to life. Now my HT2D72 is very expensive a brick.                                        Any combination of F1 + power button don't work, screen is black. Only power button for all the time is blinking on red colour.
                                 
        
Best Regards
MS





You have to log in before you can reply Login | Register

Points Rules

QQ|Dark room|Mobile|Archiver|Electronic Engineer Discuss

2021-4-22 22:52 GMT+8 , Processed in 0.210152 second(s), 23 queries .

Powered by Discuz! X3.2

© 2001-2013 Comsenz Inc.

Quick Reply To Top Return to the list