Please select To the mobile version | Continue to access the desktop computer version

Electronic Engineer Discuss

View: 1112|Reply: 5

Hantek 6022bl has corrupted eeprom

[Copy link]

1

Threads

3

Posts

3

Credits

新手上路

Rank: 1

Credits
3
Post time 2020-9-17 15:33:58 From the mobile phone | Show all posts |Read mode
I brought hantek 6022bl last month it working fine,.
But last day when I connect to computer it shows
Cypress FX2LP No EEPROM device I think that eeprom in scope is corrupted.

Can anyone solve this problem please

And how can I resolve it.



This post contains more resources

You have to Login for download or view attachment(s). No Account? Register

x
Reply

Use magic Report

1

Threads

3

Posts

3

Credits

新手上路

Rank: 1

Credits
3
 Author| Post time 2020-9-18 14:24:12 From the mobile phone | Show all posts
Anyone from hantek here?

55

Threads

217

Posts

389

Credits

版主

Rank: 7Rank: 7Rank: 7

Credits
389
Post time 2020-9-22 13:32:23 | Show all posts
Please refer to the forum to install the driver: https://www.eediscuss.com/forum. ... mp;highlight=6022BL

1

Threads

3

Posts

3

Credits

新手上路

Rank: 1

Credits
3
 Author| Post time 2020-9-24 20:43:57 | Show all posts
sir I successfuly installed the above software provided by you, but the same problem continues
device manager showing unknown device once again.

and my problem is, driver not installing.

I think I want to reflash the hantek 6022bl oscilloscope.

so I want a frimware to do that, but i don't have that. And i dont know how to do that.

It was helpful if you provide me frimware for hantek 6022bl oscilloscope.
and say how to flash it.

Thank you.



55

Threads

217

Posts

389

Credits

版主

Rank: 7Rank: 7Rank: 7

Credits
389
Post time 2020-9-25 16:07:06 | Show all posts
Mounith replied at 2020-9-24 20:43
sir I successfuly installed the above software provided by you, but the same problem continues
devi ...

The cause is driver uninstall. Please refer to the link to update the driver. https://www.eediscuss.com/forum.php?mod=viewthread&tid=9012&highlight=1703

1

Threads

2

Posts

2

Credits

新手上路

Rank: 1

Credits
2
Post time 2021-1-20 03:58:37 | Show all posts
Mounith replied at 2020-9-24 20:43
sir I successfuly installed the above software provided by you, but the same problem continues
devi ...

Hello sir,
I have the very common issue with you.
I put my device in the box for several months and was working very well before that
now it does not work .
I have checked the whole circuit my self and found no issues with it .
Then i used openhantek which is the open source hantek software and also used sigrok cli ,
which both put their own firmware while connecting to the device from USB port and they do not use the firmware on the eeprom integrated in the board , so it worked properly with both while the led blinking and 1 khz frequency on the test output of the device( there was also no frequency on the test bars because it is connected to the cypress chip directly while no boot loading is being done on the device) . I understood this eeprom HANTEK is using on this device clears itself completely if there be no voltage for a long time .
as you i am wishing hantek gives me flashing tool of device but i rather doubt they would do that because there would be no reasons for them to reproduce the device as someone else has the original firmware. but i will do my best because searching in the forum there are many others having the same issues to us.
You have to log in before you can reply Login | Register

Points Rules

QQ|Dark room|Mobile|Archiver|Electronic Engineer Discuss

2021-3-8 07:14 GMT+8 , Processed in 0.361701 second(s), 22 queries .

Powered by Discuz! X3.2

© 2001-2013 Comsenz Inc.

Quick Reply To Top Return to the list