Please select To the mobile version | Continue to access the desktop computer version

Electronic Engineer Discuss

View: 363|Reply: 9

Hantek 6022BL Windows 10 driver installation fails with "Bad Image"

[Copy link]

1

Threads

4

Posts

4

Credits

新手上路

Rank: 1

Credits
4
Post time 2019-4-20 09:00:39 | Show all posts |Read mode
Edited by raphidae at 2019-4-20 09:26

Hi,

I just received my Hantek 6022BL, but I can't get the drivers to work on Windows 10. First I downloaded the drivers from the product page (http://www.hantek.com/en/ProductDetail_2_153.html), which include drivers for "Win 10", however they're signed and dated in 2014 (when Windows 10 was released in 2015, but let's say they developed them on preview builds).

I also tried the drivers that come with the software (downloaded from the same link), they claim to be the same version, but are different size files and signed and dated from 2016, but also don't work.

Furthermore, the manual does not explain the button on the thing marked H or P, depending on which the device identifies differently to Windows. I figured out this needs to be in H for the drivers to even be detected. (What is this for??)

No matter which of the above drivers I install (and whether I choose DRIVER 1 or DRIVER 2) I get the following error:

  1. Windows cannot load the device driver for this hardware. The driver may be corrupted or missing. (Code 39)

  2. {Bad Image}
  3. %hs is either not designed to run on Windows or it contains an error. Try installing the program again using the original installation media or contact your system administrator or the software vendor for support. Error status 0x
Copy the Code
The zipfile the drivers came from was not corrupted (but I've re-downloaded just in case).
Please note that I received an 8cm CD with the device, but I can't read this disc because I have a slot-in DVD-reader. So no idea what's on there, I assume the software/drivers on the site are more current.

I also tried the drivers from https://www.eediscuss.com/forum.php?mod=viewthread&tid=6991 Hantek6022BL_Driver.zip  (which seem the same to the ones with the software, signed 2016), same error.

Microsoft Windows [Version 10.0.17763.437]

Reply

Use magic Report

1

Threads

4

Posts

4

Credits

新手上路

Rank: 1

Credits
4
 Author| Post time 2019-4-20 09:03:31 | Show all posts
Edited by raphidae at 2019-4-20 09:14

<remove> (double)

1

Threads

4

Posts

4

Credits

新手上路

Rank: 1

Credits
4
 Author| Post time 2019-4-20 09:08:52 | Show all posts
Edited by raphidae at 2019-4-20 09:14

<remove> (double)

4

Threads

35

Posts

35

Credits

新手上路

Rank: 1

Credits
35
Post time 2019-4-21 05:34:29 | Show all posts
As I already wrote many times (and you just noticed), Hantek's USB drivers are a mess. Try to do this: Open the Windows Device Manager and mark the option "Show hidden devices" in "View" menu and then remove all Hantek drivers that you see (when you are deleting a device form the list, make sure to check the option "uninstall driver").
Unplug an plug the device again to confirm that there is no driver left in the system. When you see only the yellow exclamation mark, download the latest drivers from Hantek and manually install the Win 10 driver (in the Windows Device manager right click on the device and select "update driver").
Also try to plug the device in a different USB port and make sure that both connectors of the USB cable (black and red) are plugged. Oh! and don't use any USB hub, I don't know why but hantek's USB drivers don't work through a hub, you'll get a blue screen and the computer will crash and reboot.


Regarding the button at the back, it is simple: keep it pressed (H position) to use the oscilloscope with Hantek's USB driver and software. With the button in the position P (unpressed) the device will use the fx2 usb driver, this way you can use the Saleae Logic software for the logic analyzer (limited to only 8ch but way better and much more useful than the original software). You need to unplug and plug the device again  to the usb port every time you press the button for it to work.
https://www.youtube.com/watch?v=G5tFnaFK7qs

26

Threads

1275

Posts

1436

Credits

实习版主

Rank: 7Rank: 7Rank: 7

Credits
1436
Post time 2019-4-22 13:53:35 | Show all posts
First, press H/P button to H position, and now connect the scope to your computer via the USB cable.

And refer to this post to update the driver for windows10.
https://www.eediscuss.com/forum. ... tid=9012&extra=


This post contains more resources

You have to Login for download or view attachment(s). No Account? Register

x

1

Threads

4

Posts

4

Credits

新手上路

Rank: 1

Credits
4
 Author| Post time 2019-4-25 21:04:25 | Show all posts
I did both the suggestions, and it doesn't work.

"Windows cannot load the device driver for this hardware. The driver may be corrupted or missing. (Code 39)

{Bad Image}
%hs is either not designed to run on Windows or it contains an error. Try installing the program again using the original installation media or contact your system administrator or the software vendor for support. Error status 0x"

I'm going to return it.

0

Threads

14

Posts

14

Credits

新手上路

Rank: 1

Credits
14
Post time 2019-4-26 09:13:45 | Show all posts
Sir,please wait,Hantek will try to solve your problem

0

Threads

1

Posts

1

Credits

新手上路

Rank: 1

Credits
1
Post time 2019-5-5 11:20:42 | Show all posts
Edited by Robert2308 at 2019-5-5 11:23

any driver which I downloads will not sucesse to update the driver foe Win 10. Please advise how do it?

This post contains more resources

You have to Login for download or view attachment(s). No Account? Register

x

26

Threads

1275

Posts

1436

Credits

实习版主

Rank: 7Rank: 7Rank: 7

Credits
1436
Post time 2019-5-9 16:29:50 | Show all posts
First, press H/P button to H position. If you can, please connact a adapter 5V@2A to the red connector of the usb cable. Second, connect the scope to your computer via the USB cable.
Pay attention to the sequence of operations.
And then open the device manager of your computer, right click the unknown device, select Properties.
And give me a screenshot of the Hardware ID as the following picture.






This post contains more resources

You have to Login for download or view attachment(s). No Account? Register

x

26

Threads

1275

Posts

1436

Credits

实习版主

Rank: 7Rank: 7Rank: 7

Credits
1436
Post time 2019-5-9 16:33:57 | Show all posts
And you can refer to last author in this post, he solve this problem by a reset of USB host controller and a diagnostic system reboot.
https://www.eediscuss.com/forum. ... p;extra=&page=3
You have to log in before you can reply Login | Register

Points Rules

QQ|Dark room|Mobile|Archiver|Electronic Engineer Discuss

2019-5-22 17:42 GMT+8 , Processed in 0.961890 second(s), 22 queries .

Powered by Discuz! X3.2

© 2001-2013 Comsenz Inc.

Quick Reply To Top Return to the list