Please select To the mobile version | Continue to access the desktop computer version

Electronic Engineer Discuss

 Forgot password?
 Register

扫一扫,访问微社区

12Next
Return to list New
View: 68|Reply: 10

DSO1202B "self calibration failed, error: 0x502"

[Copy link]

1

Threads

6

Posts

6

Credits

新手上路

Rank: 1

Credits
6
Post time 2017-11-10 02:49:57 | Show all posts |Read mode
Hi All!
When I do self calibration on my DSO1202B I always get "self calibration failed, error: 0x502". Sys. info is in the picture.
What's wrong?

This post contains more resources

You have to Login for download or view attachment(s). No Account? Register

x
Reply

Use magic Report

12

Threads

803

Posts

964

Credits

实习版主

Rank: 7Rank: 7Rank: 7

Credits
964
Post time 2017-11-10 15:47:49 | Show all posts
Sir, aside from self correction, is there a problem at work?
Reply Support Not support

Use magic Report

1

Threads

6

Posts

6

Credits

新手上路

Rank: 1

Credits
6
 Author| Post time 7 day(s) ago | Show all posts
I think - yes. I tried to measure a 12MHz crystal that is working for sure. At first the measurement was just perfect but then I tried again and I got ~260Hz. I push the Auto button and it that fixed the problem until some next measurement.
That happened several times even after power-down/power-up sequence.
I also tried to connect the probe to the 1kHz source of the device itself in order to calibrate but the result was the same - sometimes perfect, sometimes ugly.

Reply Support Not support

Use magic Report

12

Threads

803

Posts

964

Credits

实习版主

Rank: 7Rank: 7Rank: 7

Credits
964
Post time 7 day(s) ago | Show all posts
ludarabota replied at 2017-11-11 01:37
I think - yes. I tried to measure a 12MHz crystal that is working for sure. At first the measurement ...

Sir, please disconnect any probe or cable to the input connector and do self calibration, is there still the problem?
Reply Support Not support

Use magic Report

1

Threads

6

Posts

6

Credits

新手上路

Rank: 1

Credits
6
 Author| Post time 6 day(s) ago | Show all posts
Thank you Amy for your support.
I disconnected all the cables and this time the self-calibration passed without errors.
Next I connected the probe to the 1kHz internal source of the scope. The frequency of 1kHz was measured correctly with the exception of the wave squareness.
No matter how I turned the probe adjustment capacitor I always get the image from the attachment. I have not succeeded to obtain a square wave.
I tried with both the probes provided. The attenuation of the probe was set to x10 as well as settings in the scope.
I also tried to measure the same 12MHz known frequency and now it seems OK but I cannot guarantee for how long.
Should I do a firmware upgrade?

This post contains more resources

You have to Login for download or view attachment(s). No Account? Register

x
Reply Support Not support

Use magic Report

12

Threads

803

Posts

964

Credits

实习版主

Rank: 7Rank: 7Rank: 7

Credits
964
Post time 5 day(s) ago | Show all posts
ludarabota replied at 2017-11-12 17:36
Thank you Amy for your support.
I disconnected all the cables and this time the self-calibration pas ...

Sir, when you test the 1KHz square waveform with x10 probe, is the waveform normal?
Reply Support Not support

Use magic Report

1

Threads

6

Posts

6

Credits

新手上路

Rank: 1

Credits
6
 Author| Post time 4 day(s) ago | Show all posts
No, the 1KHz waveform is of the form given in the attached picture - see my last post. It is not rectangular.
This waveform have to be adjusted with the trimpot of the probe by using the plastic screwdriver. I tried without any luck.
Reply Support Not support

Use magic Report

12

Threads

803

Posts

964

Credits

实习版主

Rank: 7Rank: 7Rank: 7

Credits
964
Post time 4 day(s) ago | Show all posts
ludarabota replied at 2017-11-14 01:16
No, the 1KHz waveform is of the form given in the attached picture - see my last post. It is not rec ...

Sir, sorry, I make a mistake.

Do you have another socilloscope? Please check whether the probe and the 1kHz internal source of the scope are ok. If they are ok, maybe the hardware is fault.

If you don't have anothe scope, please test as following steps.
When you test the 1KHz square waveform with x1 probe, is the waveform normal?
And do the channel2 can get the normal waveform with x1 probe or with x10 probe?
And give me the results.
Reply Support Not support

Use magic Report

1

Threads

6

Posts

6

Credits

新手上路

Rank: 1

Credits
6
 Author| Post time 3 day(s) ago | Show all posts
Edited by ludarabota at 2017-11-15 16:35

Today I tested with another scope at the office (we have the same model there).
The results are attached. The scope on the right of the picture is the "healthy" one and that on the left is the "bad" one.
I attached the probe of the healthy scope to the bad one and that of the bad one to the healthy scope - i.e. one scope measures the other's 1kHz signal source.
I pressed "Auto" on both of them. Please, NOTE the amplitude/div - the healthy scope measures at 1V/div and the bad measures at 20mV/div.
Switching the probe from 10x to 1x very clearly changes the results on the healthy scope and the same procedure produces a very very minuscule change for the bad scope.
I also attached a picture with hw/sw revisions.

Edit: sorry for the probably reversed images.


This post contains more resources

You have to Login for download or view attachment(s). No Account? Register

x
Reply Support Not support

Use magic Report

12

Threads

803

Posts

964

Credits

实习版主

Rank: 7Rank: 7Rank: 7

Credits
964
Post time The day before yesterday 14:47 | Show all posts
ludarabota replied at 2017-11-15 16:32
Today I tested with another scope at the office (we have the same model there).
The results are atta ...

Sir, the hardware may be fault, please contact your seller to return factory for repair.
Reply Support Not support

Use magic Report

12Next
Return to list New
You have to log in before you can reply Login | Register

Points Rules

QQ|Dark room|Mobile|Archiver|Electronic Engineer Discuss

2017-11-18 03:23 GMT+8 , Processed in 0.135059 second(s), 23 queries .

Powered by Discuz! X3.2

© 2001-2013 Comsenz Inc.

Quick Reply To Top Return to the list